The Issue

People have reported that although they have manually set the date/time on their computer, this gets changed by the windows time server ( when connected to the Internet and for some reason it doesn't display the right date/time.

The Quick Fix

First off, check there aren't any Update for Windows 7 releases at Microsoft's Windows Update

The Long Fix

Now below are the notes I've had to try and fix this before (personally it was because Microsoft released an optional windows update that fixed my issue.

check that this issue isn't being caused by any Windows 7 desktop gadgets.

  1. Quit/close all desktop gadgets except the CPU monitor and your analogue clock.
  2. Make sure your computer is connected to the Internet
  3. Left-Click once on the clock on your taskbar
  4. Click on Change date and time settings link
  5. Click on the tab Internet Time
  6. Click on the Change Settings button
  7. Check the box next to Synchronize with an Internet time server is ticked
  8. Select an option from the dropdown menu starting with the first
  9. Click on the Update now button
  10. Text will appear beneath the button
    1. If you get an error, then select a different server from the dropdown
    2. If you get the text The clock was successfully synchronized...
      1. You can opt to untick the checkbox next to Synchronize with an Internet time server to prevent it finding the wrong time (again)
      2. Check the clock has updated in your taskbar and close the window by clicking on OK
    3. Leave your computer for a few hours and see if it keeps the time...

    If the problem persists, try changing the system registry setting as per the below. If you have never used the system registry before, ask someone who has.

    Additional (intended for Vista users)

    The following is an excerpt from

    Change the Default Update Interval

    If your clock is constantly out of sync even though it says the sync was successful, the problem could be that your computer is losing time because of a system clock problem. A workaround in this instance is to change the NTP client to update more often.

    Note: The following process requires administrator (installation) rights on your computer.

    1. Open regedit.exe through the start menu search box, and then find this registry key:
      1.  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\w32time\TimeProviders\NtpClient 
    2. Double-click on the key on the right-hand side for SpecialPollInterval

    The default time period is 7 days calculated in seconds. If you wanted to change this to update every day, you would use 86400, or 60 seconds * 60 minutes * 24 hours * 1 day.

    I wouldn’t recommend setting this to anything less than 4 hours worth, or your computer might get banned by the time servers.

    Change Your Firewall Settings

    Third party firewalls will often block the time servers, causing the sync to not work properly. If you are using McAfee or another firewall, you’ll need to use the configuration utility to unlock NPT access on UDP port 123.

    Resync your Time using the command-line

    Open a command prompt (Start > Run > Type "Command" > Click on OK) and type "w32tm /resync"


    -1 Paul W Saturday, 18th July 2015, 2:54 am
    The clock on my Win7-64 system has been nuts for over 6 months. I can rarely go more than 24 hours before the clock mystically changes. At times I've had to reset it 3 times in an hour, an hour of constant use with no rebooting or even sleep mode. It's Boom! and both time and date are way off! This thread refers to "losing time". I don't "lose" time, my time and date adopt random values, but the date is *always* advanced into the future, maybe as little as tens days, but I also recall seeing a 2021 timestamp on some of my files. My issue in not a constant, on-going timing problem, where a small error snowballs over time until the offset is big enough to draw your attention. My hardware clock works fine. Something external periodically pops in, puts the future-whammy on my date and time settings, then hides until the gremlins again feel mischievous.
    Do my symptoms describe the same issue that plagued others in this thread?
    0 Justsomestupidnameso Wednesday, 3rd June 2015, 11:25 am
    This doesn't work, it says I am not the administrator, but when I check it says I am.
    Plus why do They put this ridiculous security on the clock?
    Any human is boss enough of a jumped-up calculator!
    If these fixes worked there wouldn't be any problems to fix!
    +3 GSW Saturday, 18th April 2015, 3:45 am
    Thanks to Michael in Strawberry for his posting above. I just had similar problem with Adobe Flash Player. When I installed Flash Player 17 a few days ago, my clock stopped updating, although I hadn't realized the coincidence when the clock stopped updating. Thanks to Michael's post above, I checked my Programs and saw that the Flash update happened around the same time, while my Reader update was a couple of months ago and I had no problems after that. So, I followed his steps above, changed time zone (and the time just to test the update working), removed the Flash Player and rebooted. When the clock appeared with the updated correct minutes and seconds (proving it worked), I changed the time zone back, reinstalled Flash Player, and all is well again. What was additionally bizarre was that when I changed the time zone, from AZ to IN, the clock set to 2 hours earlier, not later like it should have, so somehow the initial Flash Player install screwed up the clock logic all together.
    +6 Alessandra Wednesday, 10th December 2014, 7:17 am
    Hi RimCountry,

    I just tried your remedy and it worked !!!! I am so happy to have found your post. I'm also a graphic designer who had the same problem. Now that it's fixed I can finally get on with the job.
    Thank you so much. :lol:

    +1 Fouch Monday, 8th December 2014, 6:46 am
    Check your BIOS clock as well. If it's losing time, the battery on your motherboard is going dead, causing the computer to lose time slowly.

    Replacing the battery in the mobo takes about 30 seconds.
    +1 Ravi G Saturday, 1st November 2014, 9:20 am
    Thank you..that solved my issue. Just wondering whether preventing my computer from synchronizing with internet time, creates some other problems with system.
    +2 Raul_McCai Friday, 13th June 2014, 3:06 pm
    For Windows 7 - - - - - - -
    Logged on as ADMIN, in Taskscheduler Under /Library/Micros oft/Windows/Tim e Syncronization open the Triggers panel and change how often the clock syncs with whatever internet time you please.

    Trying to do this as a user with the Admin passcode won't work you gotta be logged on as the administrator.
    +1 Steve_Adrine Sunday, 25th May 2014, 2:32 am
    Thank you so much. I've been troubleshooting this problem for 2 years and have tried everything; from making registry changes to changing the CMOS battery. your fix seems to have worked! I'm so happy because it was affecting everything, especially my calendaring. :D
    +20 Raul_McCai Wednesday, 21st May 2014, 7:43 pm
    Fix the clock in Windows 7 – it’s just a scheduling problem. Odds are yours is set to sync’ up to an internet clock once a week, and that just ain’t good enough.

    Do it through the Task Scheduler.
    Log on as admin' the Left Hand panel of task scheduler :/tack scheduler library/microso ft/windows/Time Synchronization , Right click that and select properties. Use that dialog box to change the schedule to "on startup."
    +12 RimCountry Tuesday, 10th September 2013, 7:09 pm

    In this order, I uninstalled Adobe Reader, changed the Time Zone on the clock to anything other than the correct one for my location, then re-booted the system. When it came back up, I re-set the clock to the correct Time Zone, then re-installed (directly from a new, free download) the latest version of Adobe Reader, then re-booted.

    That was yesterday, and the clock hasn't lost one second since. I have an atomic clock on the wall over my monitor and both clocks advance to the next minute within milliseconds of each other. I was just so thrilled with this that I had to come back to this blog and share it in the event that it just might work for someone else.

    BTW, I'm running Win7 64.

    Michael in Strawberry
    +11 RimCountry Tuesday, 10th September 2013, 7:08 pm

    I finally ran across an entry on an Adobe InDesign blog, posted by a user who, like me, was a graphic artist, and whose clock issues were messing with his workflow. He had inadvertently discovered a fix for his system while updating his creative suite. He recommended that I try the same thing, so as the last resort of a man clinging to the ragged edge of my sanity, I did... and it worked!

    +20 RimCountry Tuesday, 10th September 2013, 7:06 pm
    This is going to sound crazy, but this works!

    Over a two-day period, I tried every suggested remedy that I could find, both on the blogs and on Microsoft's outdated and virtually worthless "knowledge" base - I re-booted in Safe Mode and ran SpyBot Search & Destroy, then I replaced the battery and reset the BIOS, I selected and re-selected all the known time servers on the planet. I tried everything - even suggestions that I knew couldn't possibly resolve the issue, everything except truly dangerous things involving tampering with registry entries, and replacing the motherboard. The clock would still begin to lose time as soon as it was reset. Not only was it messing with virtually every time-sensitive application on the system, but it was literally driving me crazy.

    +6 Xanamiar Sunday, 23rd June 2013, 3:18 pm
    If you are losing time and doing everything you did didn't fix it. Replace the Cmos battery. It's a cheap battery just take it out and put a new one in ((after turning of the computer)) if the CMOS battery is bad the computer will lose time.
    0 Joel L Wednesday, 17th March 2010, 8:27 am
    True the vista section (changing the registry key) did not work for me on windows 7. My main pc is on windows 7 and I had to disable most of the 3rd-party desktop gagdets. This made the clock stable but when I switched on and off, my clock would be lost again. I updated my BIOS firmware which changed it but didn't solve it. I ended up installing optional "Updates for Windows 7" and this fixed the problem.
    +1 oceanwaves Monday, 15th March 2010, 9:23 pm
    This worked on XP and Vista, but sadly it will not work on Windows 7. The registry keys are still there, but when specialpollinte rval is adjusted to be less time it has no affect. I tried 120 seconds for a test and it did nothing. Had it worked I would have upped it to maybe an hour. Also I know it works on 120 second test on windows XP. So that should be no problem. It just isn't working on windows 7 for some reason.

    Add comment